RUN exported processing in linux


#1

hi
I want run exported file in processing in ubunto Linux…so I run this cmd on terminal: first cd to file path"/root/opt/filename/application.linux64/lib
“java -jar filename.jar”
but give this error “could not find or load main class filename”
when run “$JAVA_HOME”
SAY "/usr/ava/jdk1-1.8’ is a directory
that mean is java is in the path right?
what is my mistake
happy new year


#2

Usually you have to do more than just run a single .jar file. There are several .jar files that need to be on your classpath. Processing exports a run script file that you should be running instead of the .jar file.

That means your JAVA_HOME variable is set, but it doesn’t mean that Java is on your PATH, unless your PATH is set to include JAVA_HOME. To find out whether Java is on your path, do java -version and see what comes up. But in your case, your error is complaining about the .jar file itself, not your Java setup.


#3

I am very newbie in Linux . in processing exported file have some .jar file


about java -version


that mean is in path?
I run jar file in lib folder. that is right?

please guide me which way run the exported file
thanks very much


#4

I’m not a Linux expert, but my guess is you want to run that S3 file. (The one that just says S3, not S3.pde or S3.java. )

That’s the run script file I was talking about. Try opening it up in a basic text editor to see exactly what it’s doing.


#5

when double click on S3 file don’t happen any thing. which one is run script file? i don’t what you means.


#6

Try running it via the command line and see if you get any errors. The S3 file is a script file that runs your application.


#7

open in text


with which command can I run it on terminal?


#8

with this command run it and give below error
./S3
is this command right? and must be I use run sketch without DISPLAY?
I Run opensuse on Raspberry pi b3 now. but when run it on obunto so have this error too


#9

I correct that now run ./S3 IN ubunto and run program perfect. now must be find problem for raspberry pi. I connect monitor to raspberry but why say must run without display?


#10

in below link run the PDE file of processing but which way can script file


#11

Right, the S3 file is a script file. You run the whole file, which executes the commands inside of it.

I’ve never worked with Raspberry Pi before, but those links sounds pretty promising. Good luck.


#12

I use this command
./ filename


#13

yes I find answer. with ./filename can run each processing with one pde. for run processing files with some pdes most be use:
sudo Xvfb :1 -screen 0 1024x768x24 </dev/null &
export DISPLAY=":1"
Then, run a sketch as usual from the command line:

/home//processing/processing-java --sketch=/path/to/sketch/folder --run